1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Balló György <ballogyor+arch at gmail dot com>
5 pkgname=(libhandy libhandy-docs)
8 pkgdesc="Library full of GTK+ widgets for mobile phones"
9 url="https://gitlab.gnome.org/GNOME/libhandy"
24 checkdepends=(xorg-server-xvfb)
25 _commit=48ae7ec0f7f9ee5f666da38b0e39e66874957166 # tags/1.8.2^0
26 source=("git+https://gitlab.gnome.org/GNOME/libhandy.git#commit=$_commit")
31 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
39 arch-meson libhandy build -D gtk_doc=true
40 meson compile -C build
44 dbus-run-session xvfb-run -s '-nolisten local' \
45 meson test -C build --print-errorlogs
49 provides=(libhandy-1.so)
51 meson install -C build --destdir "$pkgdir"
53 mkdir -p doc/usr/share
54 mv {"$pkgdir",doc}/usr/share/doc
57 package_libhandy-docs() {
58 pkgdesc+=" (documentation)"
64 # vim:set sw=2 sts=-1 et: