db-move: moved linux-zen from [testing] to [extra] (x86_64)
[arch-packages.git] / qmlkonsole / repos / extra-x86_64 / PKGBUILD
blobce10a68c534119e90ab89096cab5f0a20658cf86
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=qmlkonsole
4 pkgver=23.04.0
5 pkgrel=1
6 pkgdesc='Terminal app for Plasma Mobile'
7 url='https://apps.kde.org/qmlkonsole/'
8 arch=(x86_64)
9 license=(GPL LGPL)
10 depends=(kirigami-addons qmltermwidget qt5-svg ki18n kconfig kcoreaddons kwindowsystem)
11 makedepends=(extra-cmake-modules)
12 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
13 sha256sums=('2024bda0eb31d01c7897c81a27f870af882d051918d4c2b638f8e5b657e1365a'
14             'SKIP')
15 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
16               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
17               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
19 build() {
20   cmake -B build -S $pkgname-$pkgver \
21     -DBUILD_TESTING=OFF
22   cmake --build build
25 package() {
26   DESTDIR="$pkgdir" cmake --install build