db-move: moved epiphany from [testing] to [extra] (x86_64)
[arch-packages.git] / libgadu / repos / extra-x86_64 / PKGBUILD
blob060ff2d224630363a305782a321600191a240473
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Mateusz Herych <heniekk@gmail.com>
5 pkgname=libgadu
6 pkgver=1.12.2
7 pkgrel=13
8 pkgdesc="Client-side library for the Gadu-Gadu protocol"
9 arch=('x86_64')
10 url="https://libgadu.net/"
11 license=('LGPL2.1')
12 depends=('gnutls' 'protobuf-c')
13 source=($pkgname-$pkgver.tar.gz::https://github.com/wojtekka/libgadu/archive/$pkgver.tar.gz
14         gcc10.patch)
15 sha256sums=('f53e703d7ad93ce222dbf7fc0cec77f62813af38817a3678e799e91f1c69c94d'
16             '2dae59d29aa2eb0905cc3c220041d5cfd95183276d684f36c9dc955c24080382')
18 prepare() {
19   cd $pkgname-$pkgver
20   patch -Np1 -i ../gcc10.patch
21   NOCONFIGURE=1 ./autogen.sh
24 build() {
25   cd $pkgname-$pkgver
26   ./configure --prefix=/usr --disable-static
27   make
30 check() {
31   cd $pkgname-$pkgver
32   make check
35 package() {
36   cd $pkgname-$pkgver
37   make DESTDIR="$pkgdir" install
40 # vim:set ts=2 sw=2 et: