db-move: moved epiphany from [testing] to [extra] (x86_64)
[arch-packages.git] / lprint / trunk / PKGBUILD
blob0ca2f73007eab9858e756161d3de6b64ffeb5824
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: WorMzy Tykashi <wormzy.tykashi@gmail.com>
4 pkgname=lprint
5 pkgver=1.2.0
6 pkgrel=1
7 pkgdesc="Label Printer Application"
8 arch=('x86_64')
9 url="https://www.msweet.org/lprint/"
10 license=('Apache' 'custom')
11 depends=('pappl' 'libcups' 'libpng' 'libusb' 'pam')
12 source=("https://github.com/michaelrsweet/lprint/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.sig})
13 validpgpkeys=('845464660B686AAB36540B6F999559A027815955')  # "Michael R Sweet <michael.r.sweet@gmail.com>"
14 #validpgpkeys=('9086C3CDC66C3F563CF8F405BE67C75EC81F3244') # "Michael R Sweet <msweet@msweet.org>"
15 sha256sums=('96a2f7efbbd318cc7189c4b1d59894caee02503a881a82d7a212d2a94636f95c'
16             'SKIP')
18 build() {
19   cd ${pkgname}-${pkgver}
20   ./configure --prefix=/usr --with-systemd
21   make
24 check() {
25    cd "$pkgname-$pkgver"
26 #   make -k check
29 package() {
30   cd ${pkgname}-${pkgver}
31   make DESTDIR="${pkgdir}" install
32   # add license + exception
33   install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" {LICENSE,NOTICE}
35   # workaround until next release - FS#75465 / https://github.com/michaelrsweet/lprint/pull/63
36   sed -i "s:/local::" "${pkgdir}"/usr/lib/systemd/system/lprint.service