1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 # Contributor: Gaetan Bisson <bisson@archlinux.org>
4 # Contributor: Angel Velasquez <angvp@archlinux.org>
5 # Contributor: Andrea Scarpino <andrea@archlinux.org>
6 # Contributor: Damir Perisa <damir.perisa@bluewin.ch>
7 # Contributor: Ben <ben@benmazer.net>
12 pkgdesc="Flexible, powerful, server-side application for playing music"
14 url="https://www.musicpd.org/"
31 # smbclient # disabled because of https://bugzilla.samba.org/show_bug.cgi?id=11413
78 backup=(etc/$pkgname.conf)
80 https://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig}
84 $pkgname.service.override
86 sha512sums=('54495b839d86b47ae6e2f6cf4e1baebd0e8eb924742e9db42cc7462ffc4b6f650b83f3eaea291fe905ff5f1975cf875537ffd23a111724013ce58e6df26ce36e'
88 '25a823740d92da8e186916701413114142eb6ad91a172c592e68b569c8e4f50fa99580e555ccf6cd31fc4f55a09bfe0278efa46e4e76ee0fe02846292fadf3c1'
89 '6e467481406279767b709ec6d5c06dbd825c0de09045c52ffa2d21d0604dcfe19b7a92bf42bed25163d66a3a0d1dbde6185a648b433eaf5eac56be90491e2e18'
90 'db473db27cd68994c3ee26e78e0fb34d13126301d8861563dcc12a22d62ecb14c4ffb1e0798c6aaccdff34e73bae3fbeeff7b42606c901a2d35e278865cdf35d'
91 'c1782b82f9db1d30aece43a07230c5d57370f2494a16e108af03815d83968805472f10f53ea5495cf0e08ff8f245430c3c3bc44025af43aaf9ecd12fcd6afc6c')
92 b2sums=('b218d9f477e92842638e3fba44c84957a3f656adaaf1ece998847db8d64883b8c997703206f74b37043888757f5f628799a3a35b25ea991f9ad00df1c4ad5e71'
94 '0969a3c477b6a3f34b44e067e515d7f306414dd14e0163584417b9d071e3cc825898219f7ff66ead7905b15429b8411304052d3b2b14a72e560bfabf9bf0adcf'
95 '4ab6e415284c77802a39d0913d701fe55e56f3c22b19557661fbef77e456b5e1d151da4202695282b956602e716a7afdb994aa2fc17368b9a0d0d051d47a3afb'
96 'd7b587c25dd5830c27af475a8fdd8102139d7c8fdd6f04fe23b36be030e4411582e289f575c299255ff8183096f7d47247327276f9a24641cbd032d9675b837a'
97 '753664445d7d5cc0b36f51ac66549beea403b9731cbcb81b0a782974a0a73d90559ba93e6afcaa470b6f2f5a844c09ef695bdf3b1e6dfee97aa080f41b7fe513')
98 validpgpkeys=('0392335A78083894A4301C43236E8A58C6DB4512') # Max Kellermann <max@blarg.de>
101 local _meson_options=(
102 -D documentation=enabled
110 # NOTE: sndio conflicts with alsa
111 # TODO: package adplug
112 # TODO: package shine
113 arch-meson "${_meson_options[@]}" build $pkgname-$pkgver
123 alsa-lib libasound.so
124 audiofile libaudiofile.so
125 avahi libavahi-{client,common}.so
127 chromaprint libchromaprint.so
132 ffmpeg libav{codec,filter,format,util}.so
134 fluidsynth libfluidsynth.so
136 icu libicui18n.so libicuuc.so
140 libid3tag libid3tag.so
141 libmikmod libmikmod.so
142 libmpdclient libmpdclient.so
144 libopenmpt libopenmpt.so
145 libpipewire libpipewire-0.3.so
147 libsamplerate libsamplerate.so
148 libsndfile libsndfile.so
149 libupnp libixml.so libupnp.so
151 libvorbis libvorbis{,enc}.so
156 systemd-libs libsystemd.so
157 twolame libtwolame.so
161 DESTDIR="$pkgdir" ninja -C build install
162 install -vDm 644 $pkgname-$pkgver/doc/${pkgname}conf.example -t "$pkgdir/usr/share/doc/$pkgname/"
163 install -vDm 644 $pkgname.service.override "$pkgdir/usr/lib/systemd/system/mpd.service.d/00-arch.conf"
164 install -vDm 644 $pkgname.conf -t "$pkgdir/etc/"
165 install -vDm 644 $pkgname.sysusers "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
166 install -vDm 644 $pkgname.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"