archrelease: copy trunk to extra-x86_64
[arch-packages.git] / archinstall / trunk / PKGBUILD
blobca820e338f1436c57a51e1df9fd2341a4d332fe4
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
3 # Contributor: Anton Hvornum <anton@hvornum.se>
4 # Contributor: demostanis worlds <demostanis@protonmail.com>
6 pkgname=archinstall
7 pkgver=2.5.5
8 pkgrel=1
9 pkgdesc="Just another guided/automated Arch Linux installer with a twist"
10 arch=(any)
11 url="https://github.com/archlinux/archinstall"
12 license=(GPL3)
13 depends=(
14   python
15   systemd
17 makedepends=(
18   python-build
19   python-installer
20   python-setuptools
21   python-sphinx
22   python-wheel
24 optdepends=(
25   'python-systemd: for systemd-journald support'
27 provides=(python-archinstall)
28 source=(
29   $pkgname-v$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz
30   $pkgname-v$pkgver.tar.gz.sig::$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz.sig
32 sha512sums=('0488e614ecf7e33035015b95b6ec86bd183288e85655452f31f364b906515c6854d841ac1bf60d08496065dc53c6e522d528998bf16e99ed87e93c848313f954'
33             'SKIP')
34 b2sums=('9eaffc7b99ce2999ee55e312b59ee1b0fade3066c15f07f9dfc09b5b039c705f2ba4f4695592fddfcdc48e7c83f974fb372ca96565f8997a74b10e27c5f58fe2'
35         'SKIP')
36 validpgpkeys=('256F73CEEFC6705C6BBAB20E5FBBB32941E3740A') # Anton Hvornum (Torxed) <anton@hvornum.se>
38 prepare() {
39   cd $pkgname-$pkgver
40   # use real directories for examples and profiles, as symlinks do not work
41   # with flit or setuptools PEP517 backends
42   rm -fv $pkgname/{examples,profiles}
43   mv -v examples profiles $pkgname/
46 build() {
47   cd $pkgname-$pkgver
48   python -m build --wheel --no-isolation
49   PYTHONDONTWRITEBYTECODE=1 make man -C docs
52 package() {
53   cd $pkgname-$pkgver
54   python -m installer --destdir="$pkgdir" dist/*.whl
55   install -vDm 644 docs/_build/man/archinstall.1 -t "$pkgdir/usr/share/man/man1/"