archrelease: copy trunk to extra-x86_64
[arch-packages.git] / krita / repos / extra-x86_64 / PKGBUILD
blobc8b46f55a0296f3c77a4c24656f022ec01c90574
1 # Maintainer: Antonio Rojas <arojas@archlinux,org>
3 pkgname=krita
4 _pkgver=5.1.5
5 pkgver=${_pkgver/-/}
6 pkgrel=4
7 pkgdesc='Edit and paint images'
8 arch=(x86_64)
9 url='https://krita.org'
10 license=(GPL3)
11 depends=(kitemviews kitemmodels ki18n kcompletion kguiaddons kcrash qt5-svg qt5-multimedia quazip
12          gsl libraw exiv2 openexr fftw openjpeg2 opencolorio libwebp hicolor-icon-theme)
13 makedepends=(extra-cmake-modules kdoctools boost eigen poppler-qt5 python-pyqt5 libheif
14              qt5-tools sip kseexpr libmypaint libjxl xsimd)
15 optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations'
16             'python-pyqt5: for the Python plugins' 'libheif: HEIF filter'
17             'kseexpr: SeExpr generator layer' 'kimageformats: PSD support' 'libmypaint: support for MyPaint brushes'
18             'krita-plugin-gmic: GMic plugin' 'libjxl: JPEG-XL filter')
19 source=(https://download.kde.org/stable/krita/$_pkgver/$pkgname-$_pkgver.tar.gz{,.sig}
20         find-xsimd.patch
21         https://invent.kde.org/graphics/krita/-/commit/e9184281.patch)
22 sha256sums=('1c775ebef0f799a9a6b74440c3d906ab913c27541b177ed621704de714e9a4d3'
23             'SKIP'
24             '622c9ffbbfef72dd024b391b879c79ae34da11d52b2f3488dfd8ee42bf7b453b'
25             '3db041acee92d6e4238c47ad572142a930340858703f523baa32f129e6474060')
26 validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD'  # Boudewijn Rempt <foundation@krita.org>
27               'E9FB29E74ADEACC5E3035B8AB69EB4CF7468332F'  # Dmitry Kazakov (main key) <dimula73@gmail.com>
28               '064182440C674D9F8D0F6F8B4DA79EDA231C852B') # Stichting Krita Foundation <foundation@krita.org>
30 prepare() {
31   patch -d $pkgname-$_pkgver -p1 < find-xsimd.patch
32   patch -d $pkgname-$_pkgver -p1 < e9184281.patch # Fix build with libheif 1.14.1
35 build() {
36   cmake -B build -S $pkgname-$_pkgver \
37     -DBUILD_KRITA_QT_DESIGNER_PLUGINS=ON
38   cmake --build build
41 package() {
42   DESTDIR="$pkgdir" cmake --install build