archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kwayland / trunk / PKGBUILD
blob7764a1f83398ce489881a45af10cf8b7cdd6673d
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kwayland
6 pkgver=5.104.0
7 pkgrel=1
8 pkgdesc='Qt-style Client and Server library wrapper for the Wayland libraries'
9 arch=(x86_64)
10 url='https://www.kde.org'
11 license=(LGPL)
12 depends=(qt5-wayland)
13 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc wayland-protocols plasma-wayland-protocols)
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('05eb60288e85cdbaef4acf8d3b3b1bb4a814d2cf0ce7011e0d10cbf193bfe076'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DCMAKE_INSTALL_LIBEXECDIR=lib \
23     -DBUILD_TESTING=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build