archrelease: copy trunk to extra-x86_64
[arch-packages.git] / live-media / trunk / PKGBUILD
blob99bccc9ee08c10ab82dadb264c1cd4b20ba4f3f3
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
3 # Contributor: Gilles CHAUVIN <gcnweb@gmail.com>
5 pkgname=live-media
6 pkgver=2022.12.01
7 pkgrel=1
8 pkgdesc='Set of C++ libraries for multimedia streaming'
9 url='http://live555.com/liveMedia'
10 arch=('x86_64')
11 license=('LGPL')
12 depends=('gcc-libs' 'openssl')
13 source=(https://download.videolan.org/contrib/live555/live.${pkgver}.tar.gz)
14 sha256sums=('057c1d3dc24c26b33e14c4dc3592885adf220403a1e1255e8a101e233c69c108')
15 sha512sums=('bb5dc80b5b1621e04fb8a100bd3deff190efb757da10e6cfc652d6eaa878f6a3e063b2f2219d5d83d6fb6892b55be55eafe2dd43f42a559e1f931130b45584b1')
17 prepare() {
18   cd live
19   find . -name Makefile.head | xargs sed -e 's|/local||g' -i # Fix prefix
22 build() {
23   cd live
24   sed -E 's|(-DSOCKLEN_T=socklen_t)|\1 -fPIC -DRTSPCLIENT_SYNCHRONOUS_INTERFACE=1|g' -i config.linux-with-shared-libraries
25   ./genMakefiles linux-with-shared-libraries
26   make
29 package() {
30   cd live
31   make DESTDIR="$pkgdir" install
34 # vim: ts=2 sw=2 et: