1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
5 pkgdesc='A set of Python bindings for the Qt6 toolkit'
9 url='https://riverbankcomputing.com/software/pyqt/intro'
12 depends=(qt6-base python-pyqt6-sip)
13 optdepends=('qt6-tools: QtHelp, QtDesigner bindings'
14 'qt6-svg: QtSvg bindings'
15 'qt6-declarative: QtQml bindings, qmlplugin'
16 'qt6-quick3d: QtQuick3D bindings'
17 'qt6-connectivity: QtBluetooth, QtNfc bindings'
18 'qt6-multimedia: QtMultimedia bindings'
19 'qt6-positioning: QtPositioning bindings'
20 'qt6-remoteobjects: QtRemoteObjects bindings'
21 'qt6-sensors: QtSensors bindings'
22 'qt6-serialport: QtSerialPort bindings'
23 'qt6-speech: QtTextToSpeech bindings'
24 'qt6-webchannel: QtWebChannel bindings'
25 'qt6-webengine: QtPdf bindings'
26 'qt6-websockets: QtWebSockets bindings'
27 'dbus-python: for python-dbus mainloop support')
28 makedepends=(sip pyqt-builder python-opengl dbus-python
29 qt6-tools qt6-svg qt6-declarative qt6-quick3d qt6-shadertools qt6-multimedia qt6-remoteobjects
30 qt6-positioning qt6-sensors qt6-serialport qt6-webchannel qt6-websockets qt6-connectivity qt6-speech qt6-webengine)
31 source=(https://pypi.python.org/packages/source/P/PyQt6/PyQt6-$pkgver.tar.gz)
32 sha256sums=('740244f608fe15ee1d89695c43f31a14caeca41c4f02ac36c86dfba4a5d5813d')
39 --qmake=/usr/bin/qmake6 \
40 --api-dir /usr/share/qt6/qsci/api/python \
46 package_python-pyqt6(){
47 cd PyQt6-$pkgver/build
48 make INSTALL_ROOT="$pkgdir" install
50 # compile Python bytecode
51 python -m compileall -d / "$pkgdir"/usr/lib
52 python -O -m compileall -d / "$pkgdir"/usr/lib