archrelease: copy trunk to extra-x86_64
[arch-packages.git] / simple-scan / repos / extra-x86_64 / PKGBUILD
blob46303166dcc5a13c7f8b6c326f84a2a6a4db16a5
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Thomas Dziedzic < gostrc at gmail >
3 # Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
4 # Contributor: Joeny Ang <ang(dot)joeny(at)gmail(dot)com>
6 pkgname=simple-scan
7 pkgver=42.5
8 pkgrel=1
9 pkgdesc="Simple scanning utility"
10 url="https://gitlab.gnome.org/GNOME/simple-scan"
11 arch=(x86_64)
12 license=(GPL3)
13 groups=(gnome)
14 depends=(sane dconf gtk3 colord-sane libgusb libhandy)
15 makedepends=(yelp-tools meson vala git)
16 options=(debug)
17 _commit=a7add634a357caf31e08631d63c29f1d63340934  # tags/42.5^0
18 source=("git+https://gitlab.gnome.org/GNOME/simple-scan.git#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd $pkgname
23   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd $pkgname
30 build() {
31   arch-meson $pkgname build
32   meson compile -C build
35 check() {
36   meson test -C build --print-errorlogs
39 package() {
40   meson install -C build --destdir "$pkgdir"
43 # vim:set sw=2 sts=-1 et: