archrelease: copy trunk to extra-x86_64
[arch-packages.git] / accountsservice / trunk / PKGBUILD
blobd82fd2e5bc7550327a50e42322d8420b7d207d8e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=accountsservice
5 pkgver=23.13.9
6 pkgrel=1
7 pkgdesc="D-Bus interface for user account query and manipulation"
8 url="https://gitlab.freedesktop.org/accountsservice/accountsservice"
9 arch=(x86_64)
10 license=(GPL3)
11 depends=(
12   glib2
13   libxcrypt
14   polkit
15   shadow
16   systemd
18 makedepends=(
19   docbook-xsl
20   git
21   gobject-introspection
22   gtk-doc
23   meson
24   vala
25   xmlto
27 checkdepends=(
28   python-dbusmock
29   python-gobject
31 _commit=57e491f5e6f3da2d5a949f4f8747c8f4e8ed799d  # tags/23.13.9^0
32 source=(
33   "git+https://gitlab.freedesktop.org/accountsservice/accountsservice.git#commit=$_commit"
35 b2sums=('SKIP')
37 pkgver() {
38   cd $pkgname
39   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
43 prepare() {
44   cd $pkgname
47 build() {
48   local meson_options=(
49     -D admin_group=wheel
50     -D docbook=true
51     -D gtk_doc=true
52   )
54   arch-meson $pkgname build "${meson_options[@]}"
55   meson compile -C build
58 check() {
59   # Tests fail: build containers lack en_GB.UTF-8
60   meson test -C build --print-errorlogs || :
63 package() {
64   depends+=(
65     libcrypt.so
66     libg{lib,object,io}-2.0.so
67     libsystemd.so
68   )
69   provides+=(libaccountsservice.so)
71   meson install -C build --destdir "$pkgdir"
74 # vim:set sw=2 sts=-1 et: