archrelease: copy trunk to extra-x86_64
[arch-packages.git] / cpdb-libs / trunk / PKGBUILD
blobed540340c85d4d7cba1723d81912e62b18258226
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
3 pkgname=cpdb-libs
4 pkgver=2.0b1
5 pkgrel=1
6 pkgdesc="Frontend and Backend Libraries for the common printing dialog"
7 arch=('x86_64')
8 url="https://github.com/OpenPrinting/cpdb-libs"
9 license=('MIT')
10 depends=('glib2')
11 makedepends=('python')
12 source=($url/releases/download/$pkgver/cpdb-libs-$pkgver.tar.gz)
13 sha256sums=('cae9f9c0c153ed4ef9b69409233eca078a2579fcf595ef77bd776b1dc9d19c8d')
14 #validpgpkeys=()
16 build() {
17   cd "$pkgname-$pkgver"
18   ./configure --prefix=/usr
19   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
20   make
23 check() {
24   cd "$pkgname-$pkgver"
25   make -k check
28 package() {
29   cd "$pkgname-$pkgver"
30   make DESTDIR="$pkgdir/" install
31   install -Dm644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE