1 # Mainainer: Sébastien Luttringer <seblu@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: Andreas Radke <andyrtr@archlinux.org>
8 pkgdesc='Utility programs used for creating patch files'
10 url='https://www.gnu.org/software/diffutils'
12 depends=('glibc' 'bash')
13 validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
14 source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig}
15 '01-fix-colors-test.patch'
16 '02-fix-bug-where-D-does-not-work.patch')
17 sha256sums=('d80d3be90a201868de83d78dad3413ad88160cc53bcc36eb9eaf7c20dbf023f1'
19 'bc0b6db1f90808551e376b98a5f5e235b7a33d0f09a780a2d6be476f64678ef7'
20 'a96a96267b65b5a17b0acad2064f9edede3f54462146850f9f0b5ea8ef0e7bf4')
24 # apply patch from the source array (should be a pacman feature)
26 for src in "${source[@]}"; do
29 [[ $src = *.patch ]] || continue
30 msg2 "Applying patch $src..."
31 patch -Np1 < "../$src"
37 ./configure --prefix=/usr
48 make DESTDIR="$pkgdir" install
51 # vim:set ts=2 sw=2 et: