1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
6 pkgdesc="Access and organize your e-books on GNOME"
7 url="https://wiki.gnome.org/Apps/Books"
10 depends=(evince gjs gtk3 gnome-desktop tracker3-miners webkit2gtk libgepub
11 gnome-epub-thumbnailer)
12 makedepends=(gobject-introspection git meson yelp-tools)
14 _commit=e5a6646a5586f36e0ee3167a77237b4c7eaff8e0 # tags/40.0^0
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-books.git#commit=$_commit"
16 "git+https://gitlab.gnome.org/GNOME/libgd.git")
22 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 git submodule set-url subprojects/libgd "$srcdir/libgd"
30 git -c protocol.file.allow=always submodule update
35 arch-meson $pkgname build
36 meson compile -C build
40 meson test -C build --print-errorlogs
44 meson install -C build --destdir="$pkgdir"
47 # vim:set sw=2 sts=-1 et: