archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-taquin / trunk / PKGBUILD
blob214dfb2d8a46533b2d664dafc98d721db3b3fd9f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-taquin
5 pkgver=3.38.1+r35+g35edb95
6 pkgrel=1
7 pkgdesc="Move tiles so that they reach their places"
8 url="https://wiki.gnome.org/Apps/Taquin"
9 arch=(x86_64)
10 license=(GPL3)
11 depends=(gtk3 librsvg gsound)
12 makedepends=(meson vala yelp-tools appstream-glib git)
13 groups=(gnome-extra)
14 _commit=35edb95303b75559607d0599c4424c6cbc661648  # master
15 source=("git+https://gitlab.gnome.org/GNOME/gnome-taquin.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir="$pkgdir"
40 # vim:set sw=2 sts=-1 et: