archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libzmf / trunk / PKGBUILD
blob86c57590043a7ff6799a774d05dc47ed62dbcafa
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=libzmf
4 pkgver=0.0.2
5 pkgrel=13
6 pkgdesc="a library for import of Zoner drawing and bitmap files"
7 arch=('x86_64')
8 url="https://wiki.documentfoundation.org/DLP/Libraries/libzmf"
9 license=('MPL')
10 source=(https://dev-www.libreoffice.org/src/${pkgname}/${pkgname}-${pkgver}.tar.xz)
11 depends=('librevenge' 'libpng')
12 makedepends=('boost' 'cppunit' 'doxygen')
13 sha256sums=('27051a30cb057fdb5d5de65a1f165c7153dc76e27fe62251cbb86639eb2caf22')
15 build() {
16   cd ${pkgname}-${pkgver}
17   ./configure --prefix=/usr --disable-werror
18   make
21 check() {
22   cd ${pkgname}-${pkgver}
23   make check
26 package() {
27   cd ${pkgname}-${pkgver}
28   make DESTDIR="${pkgdir}" install
29   install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"