archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-math-round / trunk / PKGBUILD
blobf81db21339f18682a83becdf4b152d320b46c6c9
1 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
2 # Contributor: François Charette <firmicus ατ gmx δοτ net>
4 pkgname=perl-math-round
5 pkgver=0.07
6 pkgrel=5
7 pkgdesc="Perl extension for rounding numbers"
8 arch=('any')
9 url="https://search.cpan.org/dist/Math-Round"
10 license=('GPL' 'PerlArtistic')
11 depends=('perl')
12 options=('!emptydirs')
13 source=("https://www.cpan.org/authors/id/G/GR/GROMMEL/Math-Round-$pkgver.tar.gz")
14 sha256sums=('73a7329a86e54a5c29a440382e5803095b58f33129e61a1df0093b4824de9327')
16 build() {
17   cd  "${srcdir}/Math-Round-${pkgver}"
18   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
19   make
22 check() {
23   cd  "${srcdir}/Math-Round-${pkgver}"
24   make test
27 package() {
28   cd  "${srcdir}/Math-Round-${pkgver}"
29   make install DESTDIR="${pkgdir}"
31   find "${pkgdir}" -name '.packlist' -delete
32   find "${pkgdir}" -name '*.pod' -delete