1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
6 pkgdesc="Python bindings for the Linux input subsystem"
7 url="https://python-evdev.readthedocs.io/en/latest/"
11 makedepends=(python-setuptools python-build python-installer python-wheel git)
12 _commit=2dd6ce6364bb67eedb209f6aa0bace0c18a3a40a # tags/v1.6.1^0
13 source=("git+https://github.com/gvalkov/python-evdev#commit=$_commit")
18 git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
27 python -m build --wheel --no-isolation
32 python -m installer --destdir="$pkgdir" dist/*.whl
33 install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE
36 # vim:set sw=2 sts=-1 et: