archrelease: copy trunk to extra-x86_64
[arch-packages.git] / signon-plugin-oauth2 / repos / extra-x86_64 / PKGBUILD
blob59909d350c78f868e150c761c26e33d04ee2a9c9
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Balló György <ballogyor+arch at gmail dot com>
4 pkgname=signon-plugin-oauth2
5 _pkgname=signon-oauth2
6 pkgver=0.25
7 pkgrel=1
8 pkgdesc='OAuth 2 plugin for signon'
9 arch=(x86_64)
10 url="https://gitlab.com/accounts-sso/signon-plugin-oauth2"
11 license=(LGPL)
12 depends=(signond)
13 makedepends=(qt5-xmlpatterns)
14 source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/accounts-sso/signon-plugin-oauth2/repository/archive.tar.gz?ref=VERSION_$pkgver")
15 sha256sums=('f750a1e767c1977d73895b7aa7d5dca5494e4cbc53cf57c7e6c311933701ae52')
17 prepare() {
18   cd signon-plugin-oauth2-VERSION_$pkgver-*
20   sed -i '/-Werror/d' common-project-config.pri
22   # Do not install tests and example
23   echo 'INSTALLS =' >>tests/tests.pro
24   echo 'INSTALLS =' >>example/example.pro
27 build() {
28   cd signon-plugin-oauth2-VERSION_$pkgver-*
30   qmake-qt5 PREFIX=/usr LIBDIR=/usr/lib
31   make
34 package() {
35   cd signon-plugin-oauth2-VERSION_$pkgver-*
37   make INSTALL_ROOT="$pkgdir" install