archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xmlsec / trunk / PKGBUILD
blob370b8b28c805283a1ec882b04e96c24161a243c9
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Hussam Al-Tayeb <ht990332@gmail.com>
5 pkgname=xmlsec
6 pkgver=1.2.37
7 pkgrel=1
8 pkgdesc="XML Security Library is a C library based on LibXML2"
9 license=('custom')
10 arch=('x86_64')
11 url="https://www.aleksey.com/xmlsec/index.html"
12 depends=('libxslt' 'openssl' 'gnutls' 'nss' 'libltdl')
13 provides=('libxmlsec1.so' 'libxmlsec1-openssl.so' 'libxmlsec1-nss.so' 'libxmlsec1-gnutls.so' 'libxmlsec1-gcrypt.so')
14 #source=(https://www.aleksey.com/xmlsec/download/${pkgname}1-${pkgver}.{tar.gz,sig}) # signature file not compatible
15 source=(https://www.aleksey.com/xmlsec/download/${pkgname}1-${pkgver}.tar.gz)
16 sha256sums=('5f8dfbcb6d1e56bddd0b5ec2e00a3d0ca5342a9f57c24dffde5c796b2be2871c')
17 #validpgpkeys=('') #
19 build() {
20   cd ${pkgname}1-${pkgver}
21   ./configure --prefix=/usr --disable-static
22   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
23   make
26 check() {
27   cd ${pkgname}1-$pkgver
28   make check
31 package() {
32   cd ${pkgname}1-${pkgver}
33   make DESTDIR="${pkgdir}" install
34   install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"