archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libdvdread / trunk / PKGBUILD
blobdae86cfe492283d01ffcb2b2cdd98e3b2afbdada
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Thomas Baechler <thomas@archlinux.org>
3 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
5 pkgname=libdvdread
6 pkgver=6.1.2
7 pkgrel=1
8 pkgdesc="Provides a simple foundation for reading DVD video disks"
9 arch=(x86_64)
10 url="https://www.videolan.org/developers/libdvdnav.html"
11 license=('GPL')
12 depends=('glibc')
13 makedepends=('libdvdcss' 'git')
14 optdepends=('libdvdcss: for decoding encrypted DVDs')
15 _commit=37e2354e016648f7c74ad48fcb5524919bb228de
16 source=("git+https://code.videolan.org/videolan/libdvdread.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed -e 's/-/+/g'
24 prepare() {
25   cd $pkgname
26   autoreconf -fi
29 build() {
30   cd $pkgname
31   ./configure --prefix=/usr
32   make
35 package() {
36   cd $pkgname
37   make DESTDIR="${pkgdir}" install