1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Pierre Schmitz <pierre@archlinux.de>
8 pkgdesc='A high performance Unix-based HTTP server'
10 url='https://www.apache.org/dist/httpd'
13 etc/httpd/conf/httpd.conf
14 etc/httpd/conf/extra/httpd-{autoindex,dav,default,info,languages}.conf
15 etc/httpd/conf/extra/httpd-{manual,mpm,multilang-errordoc}.conf
16 etc/httpd/conf/extra/httpd-{ssl,userdir,vhosts}.conf
17 etc/httpd/conf/extra/proxy-html.conf
18 etc/httpd/conf/{mime.types,magic}
21 provides=('mod_proxy_uwsgi')
22 conflicts=('mod_proxy_uwsgi')
23 replaces=('mod_proxy_uwsgi')
24 depends=('zlib' 'apr-util' 'pcre2' 'libnghttp2' 'openssl' 'libxcrypt')
25 makedepends=('libxml2' 'lua' 'curl' 'brotli' 'jansson')
27 'lua: for mod_lua module'
28 'libxml2: for mod_proxy_html, mod_xml2enc modules'
29 'curl: for mod_md module'
30 'jansson: for mod_md module'
31 'brotli: for mod_brotli module'
32 'uwsgi: for mod_proxy_uwsgi module'
33 'lynx: apachectl status'
34 'perl: for apxs and dbmmanage'
37 https://www.apache.org/dist/httpd/httpd-${pkgver}.tar.bz2{,.asc}
43 sha256sums=('eb397feeefccaf254f8d45de3768d9d68e8e73851c49afd5b7176d1ecf80c340'
45 '63da1a420f4714a3e7af2672d28384419cc7eedbe7bf35baebd02938fabc15bf'
46 '0bbbfae23a917b2fce0bf8f900f60319b50769224a96314e9301a75ccd078e16'
47 'f574bac6d5f398e7a649fc0e1ca66ff01ad4ef34dac71258e93d8a9d9a2b3960'
48 'dda05c6e76f12624e418ca18a36f2e90ec1c5b1cc52fed7142fce6076ec413f3')
49 # following keys are coming from https://downloads.apache.org/httpd/KEYS
50 validpgpkeys=('A93D62ECC3C8EA12DB220EC934EA76E6791485A8' # Jim Jagielski
51 'B9E8213AEFB861AF35A41F2C995E35221AD84DFF'
52 'C55AB7B9139EB2263CD1AABC19B033D1760C227B' # christophe.jaillet@wanadoo.fr
53 '26F51EF9A82F4ACB43F1903ED377C9E7D1944C66' # Stefan Eissing (icing) <stefan@eissing.org>
54 'E3480043595621FE56105F112AB12A7ADC55C003') # Daniel Ruggeri
60 sed -e 's#User daemon#User http#' \
61 -e 's#Group daemon#Group http#' \
62 -i docs/conf/httpd.conf.in
64 cat "${srcdir}/arch.layout" >> config.layout
70 ./configure --sbindir=/usr/bin \
71 --enable-layout=Arch \
72 --enable-mpms-shared=all \
73 --enable-modules=all \
74 --enable-mods-shared=all \
77 --with-suexec-caller=http \
78 --with-suexec-docroot=/srv/http \
79 --with-suexec-logfile=/var/log/httpd/suexec.log \
80 --with-suexec-bin=/usr/bin/suexec \
81 --with-suexec-uidmin=99 --with-suexec-gidmin=99 \
82 --enable-ldap --enable-authnz-ldap --enable-authnz-fcgi \
83 --enable-cache --enable-disk-cache --enable-mem-cache --enable-file-cache \
84 --enable-ssl --with-ssl \
85 --enable-deflate --enable-cgi --enable-cgid \
86 --enable-proxy --enable-proxy-connect \
87 --enable-proxy-http --enable-proxy-ftp \
88 --enable-dbd --enable-imagemap --enable-ident --enable-cern-meta \
89 --enable-lua --enable-xml2enc --enable-http2 \
90 --enable-proxy-http2 --enable-md --enable-brotli \
91 --with-apr=/usr/bin/apr-1-config \
92 --with-apr-util=/usr/bin/apu-1-config \
101 make DESTDIR="${pkgdir}" install
103 install -D -m644 "${srcdir}/httpd.logrotate" "${pkgdir}/etc/logrotate.d/httpd"
104 install -D -m644 "${srcdir}/apache.tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/apache.conf"
105 install -D -m644 "${srcdir}/httpd.service" "${pkgdir}/usr/lib/systemd/system/httpd.service"
106 install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
108 # symlinks for /etc/httpd
109 # do we really need this symlink?
110 ln -fs /usr/lib/httpd/modules "${pkgdir}/etc/httpd/modules"
113 sed -e 's#/usr/lib/httpd/modules/#modules/#' \
114 -e 's|#\(LoadModule negotiation_module \)|\1|' \
115 -e 's|#\(LoadModule include_module \)|\1|' \
116 -e 's|#\(LoadModule userdir_module \)|\1|' \
117 -e 's|#\(LoadModule slotmem_shm_module \)|\1|' \
118 -e 's|#\(Include conf/extra/httpd-multilang-errordoc.conf\)|\1|' \
119 -e 's|#\(Include conf/extra/httpd-autoindex.conf\)|\1|' \
120 -e 's|#\(Include conf/extra/httpd-languages.conf\)|\1|' \
121 -e 's|#\(Include conf/extra/httpd-userdir.conf\)|\1|' \
122 -e 's|#\(Include conf/extra/httpd-default.conf\)|\1|' \
123 -e 's|#\(Include conf/extra/httpd-mpm.conf\)|\1|' \
124 -i "${pkgdir}/etc/httpd/conf/httpd.conf"
127 rm -r "${pkgdir}/usr/share/httpd/manual"
128 rm -r "${pkgdir}/etc/httpd/conf/original"
129 rm -r "${pkgdir}/srv/"
130 rm -r "${pkgdir}/run"