1 # Maintainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
8 pkgdesc='GNU compression utility'
10 url='https://www.gnu.org/software/gzip/'
13 depends=('glibc' 'bash' 'less')
14 validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
15 source=("https://ftp.gnu.org/pub/gnu/gzip/gzip-$pkgver.tar.xz"{,.sig})
16 sha256sums=('ce5e03e519f637e1f814011ace35c4f87b33c0bbabeec35baf5fbd3479e91956'
20 # apply patch from the source array (should be a pacman feature)
22 for filename in "${source[@]}"; do
23 if [[ "$filename" =~ \.patch$ ]]; then
24 echo "Applying patch ${filename##*/}"
25 patch -p1 -N -i "$srcdir/${filename##*/}"
33 ./configure --prefix=/usr
44 make prefix="$pkgdir/usr" install
47 # vim:set ts=2 sw=2 et: