archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gzip / trunk / PKGBUILD
blob49afb06a586e6f039a98b7ed275316e5404ad91c
1 # Maintainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
5 pkgname=gzip
6 pkgver=1.12
7 pkgrel=1
8 pkgdesc='GNU compression utility'
9 arch=('x86_64')
10 url='https://www.gnu.org/software/gzip/'
11 license=('GPL3')
12 groups=('base-devel')
13 depends=('glibc' 'bash' 'less')
14 validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
15 source=("https://ftp.gnu.org/pub/gnu/gzip/gzip-$pkgver.tar.xz"{,.sig})
16 sha256sums=('ce5e03e519f637e1f814011ace35c4f87b33c0bbabeec35baf5fbd3479e91956'
17             'SKIP')
18 prepare() {
19   cd $pkgname-$pkgver
20   # apply patch from the source array (should be a pacman feature)
21   local filename
22   for filename in "${source[@]}"; do
23     if [[ "$filename" =~ \.patch$ ]]; then
24       echo "Applying patch ${filename##*/}"
25       patch -p1 -N -i "$srcdir/${filename##*/}"
26     fi
27   done
28   :
31 build() {
32   cd $pkgname-$pkgver
33   ./configure --prefix=/usr
34   make
37 check() {
38   cd $pkgname-$pkgver
39   make check
42 package() {
43   cd $pkgname-$pkgver
44   make prefix="$pkgdir/usr" install
47 # vim:set ts=2 sw=2 et: