archrelease: copy trunk to extra-x86_64
[arch-packages.git] / imath / trunk / PKGBUILD
blob8b3a5f93ac7b66c423cb31312c9a18e706655b96
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=imath
4 pkgver=3.1.5
5 pkgrel=3
6 pkgdesc='A C++ and python library of 2D and 3D vector, matrix, and math operations for computer graphics'
7 url='https://www.openexr.com/'
8 arch=(x86_64)
9 license=(BSD)
10 depends=(gcc-libs)
11 optdepends=('python: python bindings' 'boost-libs: python bindings')
12 makedepends=(cmake python boost)
13 source=(https://github.com/AcademySoftwareFoundation/Imath/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('1e9c7c94797cf7b7e61908aed1f80a331088cc7d8873318f70376e4aed5f25fb')
16 build() {
17   cmake -B build -S Imath-$pkgver \
18     -DCMAKE_INSTALL_PREFIX=/usr \
19     -DPYTHON=ON
20   cmake --build build
23 package() {
24   DESTDIR="$pkgdir" cmake --install build
25   install -Dm644 Imath-$pkgver/LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname