archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kaccounts-integration / repos / extra-x86_64 / PKGBUILD
blobc5d35e01e96b0210df8b35fee7237eeaf28523f1
1 # Maintainer: Antonio Rojas <arojas@archlinux.org> 
3 pkgname=kaccounts-integration
4 pkgver=22.08.2
5 pkgrel=1
6 pkgdesc='Online account management system and its Plasma integration components'
7 arch=(x86_64)
8 url='https://www.kde.org/'
9 license=(GPL)
10 depends=(kcmutils signon-kwallet-extension signon-plugin-oauth2 signon-ui)
11 makedepends=(extra-cmake-modules kdoctools)
12 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
13 sha256sums=('583c35f1fd11848ffabc8b78e86e6a50f70a0be954b6d09ab992a8224e0a6a98'
14             'SKIP')
15 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
16               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
17               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
18 options=(debug)
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build