1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
7 pkgdesc='Reference implementation of the AppImage specification'
9 url='https://appimage.org/'
11 depends=(libarchive squashfuse boost-libs librsvg)
12 makedepends=(cmake wget vim desktop-file-utils boost xdg-utils-cxx)
13 source=(https://github.com/AppImage/libappimage/archive/v$_pkgver/$pkgname-$_pkgver.tar.gz)
14 sha256sums=('2c4e18860a790c5959da6eb064cbd07f165fe6a9b15989491a3a3f176d06af31')
17 cmake -B build -S $pkgname-$_pkgver \
18 -DCMAKE_INSTALL_PREFIX=/usr \
19 -DCMAKE_C_FLAGS="$CFLAGS -ffat-lto-objects" \
21 -DUSE_SYSTEM_SQUASHFUSE=ON \
22 -DUSE_SYSTEM_LIBARCHIVE=ON \
23 -DUSE_SYSTEM_BOOST=ON \
24 -DUSE_SYSTEM_XDGUTILS=ON \
30 DESTDIR="$pkgdir" cmake --install build