archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-quick3dphysics / trunk / PKGBUILD
blob659838f49e69ef181ebe6099c4a94be3400a44da
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-quick3dphysics
5 _qtver=6.4.0
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Physics engine integration for Qt Quick 3D'
12 depends=(qt6-quick3d)
13 makedepends=(cmake ninja qt6-shadertools)
14 groups=(qt6)
15 options=(debug)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('dc59443434d1255fb0cfc50c28ccf391e50745d67014b4aa787cd7571c28fd07')
20 build() {
21   cmake -B build -S $_pkgfn -G Ninja \
22     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build
29   install -d "$pkgdir"/usr/share/licenses
30   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname