archrelease: copy trunk to extra-x86_64
[arch-packages.git] / x264 / repos / extra-x86_64 / PKGBUILD
bloba91f7241d2611f68e8c67119ddf4a0ef6bfd8907
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
4 # Contributor: damir <damir@archlinux.org>
5 # Contributor: Paul Mattal <paul@archlinux.org>
7 pkgname=x264
8 pkgver=0.164.r3095.baee400
9 pkgrel=4
10 epoch=3
11 pkgdesc='Open Source H264/AVC video encoder'
12 arch=(x86_64)
13 url=https://www.videolan.org/developers/x264.html
14 license=(GPL)
15 depends=(liblsmash.so)
16 makedepends=(
17   git
18   nasm
20 provides=(
21   libx264
22   libx264.so
24 conflicts=(
25   libx264
26   libx264-10bit
27   libx264-all
29 replaces=(
30   libx264
31   libx264-10bit
32   libx264-all
34 options=(debug)
35 _commit=baee400fa9ced6f5481a728138fed6e867b0ff7f  # master
36 source=(git+https://code.videolan.org/videolan/x264.git#commit=${_commit})
37 sha256sums=(SKIP)
39 pkgver() {
40   cd x264
41   ./version.sh | grep X264_POINTVER | sed -r 's/^#define X264_POINTVER "([0-9]+\.[0-9]+)\.([0-9]+) (.*)"$/\1.r\2.\3/'
44 build() {
45   cd x264
46   ./configure \
47     --prefix=/usr \
48     --enable-shared \
49     --enable-pic \
50     --enable-lto \
51     --disable-avs
52   make
55 package() {
56   make -C x264 DESTDIR="${pkgdir}" BASHCOMPLETIONSDIR="/usr/share/bash-completion/completions" install-cli install-lib-shared install-bashcompletion
59 # vim: ts=2 sw=2 et: