upgpkg: emacs 28.1-1
[arch-packages.git] / kget / trunk / PKGBUILD
blob5f9fb343f82015ea3ff98f68731d3b695933024a
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kget
6 pkgver=21.12.3
7 pkgrel=2
8 pkgdesc='Download Manager'
9 url='https://apps.kde.org/kget/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-network)
13 depends=(qca-qt5 qgpgme plasma-workspace kdelibs4support)
14 makedepends=(extra-cmake-modules boost libktorrent libmms kdoctools kdesignerplugin kinit)
15 optdepends=('libktorrent: torrent support' 'libmms: MMS support')
16 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('9460f6890e66b252bc8cad5414e0aaf2d0d48070bddb1aec61ea90fff74b44f0'
18             'SKIP')
19 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
20               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
21               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
22 options=(debug)
24 build() {
25   cmake -B build -S $pkgname-$pkgver \
26     -DBUILD_TESTING=OFF
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build