upgpkg: emacs 28.1-1
[arch-packages.git] / perl-math-round / trunk / PKGBUILD
blob8823d4e00664d184d4a8eb08d97d58581af53c71
1 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
2 # Contributor: François Charette <firmicus ατ gmx δοτ net>
4 pkgname=perl-math-round
5 pkgver=0.07
6 pkgrel=4
7 pkgdesc="Perl extension for rounding numbers"
8 arch=('any')
9 url="https://search.cpan.org/dist/Math-Round"
10 license=('GPL' 'PerlArtistic')
11 depends=('perl')
12 options=('!emptydirs')
13 source=("https://www.cpan.org/authors/id/G/GR/GROMMEL/Math-Round-$pkgver.tar.gz")
14 md5sums=('b74c5d2a3f891c19dafd7ce638732fd1')
16 build() {
17   cd  "${srcdir}/Math-Round-${pkgver}"
18   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
19   make
22 check() {
23   cd  "${srcdir}/Math-Round-${pkgver}"
24   make test
27 package() {
28   cd  "${srcdir}/Math-Round-${pkgver}"
29   make install DESTDIR="${pkgdir}"
31   find "${pkgdir}" -name '.packlist' -delete
32   find "${pkgdir}" -name '*.pod' -delete