archrelease: copy trunk to extra-x86_64
[arch-packages.git] / feh / trunk / PKGBUILD
blobe01fbd4676fbd222bcefb7750f4fa3fbc8afb91d
1 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: dorphell <dorphell@archlinux.org>
4 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
6 pkgname=feh
7 pkgver=3.8
8 pkgrel=2
9 pkgdesc='Fast and light imlib2-based image viewer'
10 url='https://feh.finalrewind.org/'
11 license=('custom:MIT')
12 arch=('x86_64')
13 depends=('curl' 'file' 'imlib2' 'libexif' 'libxinerama')
14 optdepends=('imagemagick: support more file formats'
15             'jpegexiforient: set exif rotation tag')
16 makedepends=('libxt')
17 validpgpkeys=('781BB7071C6BF648EAEB08A1100D5BFB5166E005')
18 source=("${url}${pkgname}-${pkgver}.tar.bz2"{,.asc}
19         '0001-libmagic.patch')
20 sha256sums=('7f3c34552b39336d7ebee2d7c4bf5697aaaa2c6c102c357f6e82ea240bd62ba9'
21             'SKIP'
22             'cc2c7ca77c710001339cceb78225119e910bc6949ab2a3380b90caf84c0d3e41')
24 prepare() {
25         cd "${srcdir}/${pkgname}-${pkgver}"
26         patch -Np1 < ../0001-libmagic.patch
29 build() {
30         cd "${srcdir}/${pkgname}-${pkgver}"
31         make PREFIX=/usr \
32                 exif=1 \
33                 help=1 \
34                 inotify=1 \
35                 stat64=1
38 package() {
39         cd "${srcdir}/${pkgname}-${pkgver}"
40         make PREFIX=/usr DESTDIR="${pkgdir}" install
41         install -D -m0644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"