archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-font-viewer / trunk / PKGBUILD
blobeb369708106dfd7fc160ad98d3ec295a1939800b
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-font-viewer
4 pkgver=41.0
5 pkgrel=1
6 pkgdesc="A font viewer utility for GNOME"
7 url="https://gitlab.gnome.org/GNOME/gnome-font-viewer"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(gtk3 gnome-desktop libhandy)
11 makedepends=(git meson)
12 groups=(gnome)
13 _commit=6723c64b9aef44b6c6e36e6a1c66f3d587e649ce  # tags/41.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-font-viewer.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 build() {
23   arch-meson $pkgname build
24   meson compile -C build
27 check() {
28   meson test -C build --print-errorlogs
31 package() {
32   meson install -C build --destdir "$pkgdir"