archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-sharp / trunk / PKGBUILD
blob59d46d6f94dc4a36accee2357b45cddd3eb669a1
1 # Maintainer: tobias <tobias@archlinux.org>
3 pkgbase=gnome-sharp
4 pkgname=('gnome-sharp' 'art-sharp' 'gconf-sharp' 'gconf-sharp-peditors' 'libgnome-sharp' 'gnome-vfs-sharp')
5 pkgver=2.24.2
6 pkgrel=4
7 arch=(x86_64)
8 license=(LGPL)
9 url="http://gtk-sharp.sourceforge.net"
10 makedepends=('gtk-sharp-2' 'libgnomeui' 'monodoc')
11 source=(https://download.gnome.org/sources/gnome-sharp/2.24/${pkgbase}-${pkgver}.tar.bz2
12         02_fix_pkg-config_paths.patch
13         04_initialize_dbus_glib_threading.patch)
14 md5sums=('3b38f53960c736d4afb8f04204efe98b'
15          'a8c1bf57a384f5fc20a5890f9f1cef5a'
16          '90cd7ea88aaa3011522376153433d115')
18 build() {
19   # get rid of that .wapi errors; thanks to brice
20   export MONO_SHARED_DIR="${srcdir}/weird"
21   mkdir -p "${MONO_SHARED_DIR}"
23   cd "${srcdir}/${pkgbase}-${pkgver}"
24   patch -Np1 -i ../04_initialize_dbus_glib_threading.patch
25   patch -Np1 -i ../02_fix_pkg-config_paths.patch
26   ./configure --prefix=/usr --sysconfdir=/etc
27   make
30 package_gnome-sharp() {
31   pkgdesc="GNOME bindings for C#"
32   depends=('art-sharp' 'gconf-sharp' 'gconf-sharp-peditors' 'libgnome-sharp' 'gnome-vfs-sharp')
35 package_art-sharp() {
36   pkgdesc="Mono bindings for libart"
37   depends=('gtk-sharp-2' 'libart-lgpl')
39   cd "${srcdir}/${pkgbase}-${pkgver}"
40   make -C art install DESTDIR="${pkgdir}"
43 package_gconf-sharp() {
44   pkgdesc="Mono bindings for GConf"
45   depends=('gtk-sharp-2' 'gconf')
47   cd "${srcdir}/${pkgbase}-${pkgver}"
48   make -C gconf/GConf install DESTDIR="${pkgdir}"
49   make -C gconf/tools install DESTDIR="${pkgdir}"
52 package_gconf-sharp-peditors() {
53   pkgdesc="Mono bindings for GConf - Property Editing classes"
54   depends=('gconf-sharp' 'libgnome-sharp')
56   cd "${srcdir}/${pkgbase}-${pkgver}"
57   make -C gconf/GConf.PropertyEditors install DESTDIR="${pkgdir}"
60 package_libgnome-sharp() {
61   pkgdesc="Mono bindings for libgnome"
62   depends=('art-sharp' 'gnome-vfs-sharp' 'libgnomeui')
64   cd "${srcdir}/${pkgbase}-${pkgver}"
65   make -C gnome install DESTDIR="${pkgdir}"
68 package_gnome-vfs-sharp() {
69   pkgdesc="Mono bindings for GNOME-VFS"
70   depends=('gtk-sharp-2' 'gnome-vfs')
72   cd "${srcdir}/${pkgbase}-${pkgver}"
73   make -C gnomevfs install DESTDIR="${pkgdir}"