archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kscreenlocker / trunk / PKGBUILD
blob7db1b75e2d59f393da24bdb4b177d49e8f7510e7
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=kscreenlocker
4 pkgver=5.24.2
5 pkgrel=1
6 pkgdesc='Library and components for secure lock screen architecture'
7 arch=(x86_64)
8 url='https://kde.org/plasma-desktop/'
9 license=(LGPL)
10 groups=(plasma)
11 depends=(layer-shell-qt kidletime kwayland kdeclarative perl)
12 makedepends=(extra-cmake-modules kdoctools kcmutils libxcursor)
13 optdepends=('kcmutils: configuration module')
14 source=(https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
15 sha256sums=('fcd9d5be26409819903b445d2ebe888ea2e7cba289304b80462e9d701e06d3e5'
16             'SKIP')
17 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
18               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
19               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
20               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
21 options=(debug)
23 build() {
24   cmake -B build -S $pkgname-$pkgver \
25     -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
26     -DBUILD_TESTING=OFF
27   cmake --build build
30 package() {
31   DESTDIR="$pkgdir" cmake --install build