archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libtommath / trunk / PKGBUILD
blob8f87587fc0adc7cae9ecfdc151d901e7774060d1
1 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
2 # Contributor: suasageandeggs <s_stoakley@hotmail.co.uk>
3 # Contributor: Michael Fellinger <manveru@www.weez-int.com>
5 pkgname=libtommath
6 pkgver=1.2.0
7 pkgrel=3
8 pkgdesc="Highly optimized and portable routines for integer based number theoretic applications"
9 url="http://www.libtom.org/"
10 license=('custom')
11 arch=('x86_64')
12 depends=('glibc')
13 source=("https://github.com/libtom/libtommath/releases/download/v$pkgver/ltm-$pkgver.tar.xz")
14 sha256sums=('b7c75eecf680219484055fcedd686064409254ae44bc31a96c5032843c0e18b1')
16 build() {
17   cd $pkgname-$pkgver
19   make -f makefile.shared IGNORE_SPEED=1
22 package() {
23   cd $pkgname-$pkgver
25   make -f makefile.shared PREFIX=/usr DESTDIR="$pkgdir" INSTALL_GROUP=root install
26   install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"