archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pygobject / repos / extra-x86_64 / PKGBUILD
blobe5062a6a93d590ccdaf4c6ef20f05342547f8d03
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgbase=pygobject
5 pkgname=(python-gobject)
6 pkgver=3.42.0
7 pkgrel=3
8 pkgdesc="Python Bindings for GLib/GObject/GIO/GTK+"
9 url="https://wiki.gnome.org/Projects/PyGObject"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(gobject-introspection-runtime python)
13 makedepends=(python-cairo gobject-introspection git meson)
14 checkdepends=(python-pytest gtk3 xorg-server-xvfb)
15 optdepends=('cairo: Cairo bindings')
16 provides=("pygobject-devel=$pkgver")
17 conflicts=(pygobject-devel)
18 replaces=('pygobject-devel<=3.36.1-1')
19 _commit=d612f3cc675a1838bc5a18061df040ab6405fd31  # tags/3.42.0^0
20 source=("git+https://gitlab.gnome.org/GNOME/pygobject.git#commit=$_commit")
21 sha256sums=('SKIP')
23 pkgver() {
24   cd pygobject
25   git describe --tags | sed 's/-/+/g'
28 prepare() {
29   cd pygobject
32 build() {
33   arch-meson pygobject build
34   meson compile -C build
37 check() {
38   xvfb-run -s '-nolisten local' meson test -C build --print-errorlogs
41 package_python-gobject() {
42   meson install -C build --destdir "$pkgdir"
43   python -m compileall -d /usr/lib "$pkgdir/usr/lib"
44   python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
47 # vim:set sw=2 et: