db-move: moved gnome-online-accounts from [testing] to [extra] (x86_64)
[arch-packages.git] / gnome-photos / repos / testing-x86_64 / PKGBUILD
blobde04382356f67513f549afe0e852601e094be8f8
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-photos
4 pkgver=44.0
5 pkgrel=3
6 epoch=1
7 pkgdesc="Access, organize, and share your photos on GNOME"
8 url="https://wiki.gnome.org/Apps/Photos"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(
12   babl
13   dleyna
14   gegl
15   geocode-glib-2
16   gnome-online-accounts
17   gsettings-desktop-schemas
18   gtk3
19   libdazzle
20   libgexiv2
21   libhandy
22   libportal-gtk3
23   librsvg
24   tracker3-miners
26 makedepends=(
27   docbook-xsl
28   git
29   meson
30   python
31   yelp-tools
33 groups=(gnome)
34 _commit=a0eb37bfb6760aa1414fa41ee1ff007336301b8c  # tags/44.0^0
35 source=(
36   "git+https://gitlab.gnome.org/GNOME/gnome-photos.git#commit=$_commit"
37   "git+https://gitlab.gnome.org/GNOME/libgd.git"
39 b2sums=('SKIP'
40         'SKIP')
42 pkgver() {
43   cd $pkgname
44   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
47 prepare() {
48   cd $pkgname
50   git submodule init
51   git submodule set-url subprojects/libgd "$srcdir/libgd"
52   git -c protocol.file.allow=always submodule update
55 build() {
56   local meson_options=(
57     -D manuals=true
58   )
60   arch-meson $pkgname build "${meson_options[@]}"
61   meson compile -C build
64 package() {
65   meson install -C build --destdir "$pkgdir"
68 # vim:set sw=2 sts=-1 et: