upgpkg: maxima 5.46.0-9 (sbcl rebuild)
[arch-packages.git] / cheese / repos / extra-x86_64 / PKGBUILD
blob8d12b6cea33f3fcf45be5675fab3a237fad8a5eb
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=cheese
5 pkgname=(cheese libcheese)
6 pkgver=43.0
7 pkgrel=1
8 pkgdesc="Take photos and videos with your webcam, with fun graphical effects"
9 url="https://wiki.gnome.org/Apps/Cheese"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(gtk3 gstreamer gst-plugins-bad gst-plugins-base gst-plugins-good clutter-gst clutter-gtk
13          libcanberra librsvg gnome-desktop libgudev dconf gnome-video-effects)
14 makedepends=(gobject-introspection vala git appstream-glib meson yelp-tools)
15 checkdepends=(xorg-server-xvfb)
16 options=(debug)
17 _commit=9e89a0da8d6d0da14b0b461051c064c419fc86d5  # tags/43.0^0
18 source=("git+https://gitlab.gnome.org/GNOME/cheese.git#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd cheese
23   git describe --tags | sed 's/\.\([a-z]\)/\1/;s/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd cheese
30 build() {
31   arch-meson cheese build -D tests=true
32   meson compile -C build
35 check() (
36   export GSETTINGS_SCHEMA_DIR="$PWD/cheese/data"
37   glib-compile-schemas "$GSETTINGS_SCHEMA_DIR"
39   dbus-run-session xvfb-run -s '-nolisten local' \
40     meson test -C build --print-errorlogs
43 _pick() {
44   local p="$1" f d; shift
45   for f; do
46     d="$srcdir/$p/${f#$pkgdir/}"
47     mkdir -p "$(dirname "$d")"
48     mv "$f" "$d"
49     rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
50   done
53 package_cheese() {
54   depends+=("libcheese=$pkgver-$pkgrel")
55   groups=(gnome)
57   meson install -C build --destdir "$pkgdir"
59   cd "$pkgdir"
61   _pick libs usr/include
62   _pick libs usr/lib/{girepository-1.0,libcheese*,pkgconfig}
63   _pick libs usr/share/{gir-1.0,glib-2.0/schemas,gtk-doc}
66 package_libcheese() {
67   pkgdesc="Webcam widget for Clutter and GTK"
68   depends=(clutter clutter-gtk clutter-gst gdk-pixbuf2 glib2 gtk3 libcanberra
69            gstreamer gst-plugins-base-libs gst-plugins-bad-libs)
70   provides=(libcheese.so libcheese-gtk.so)
71   mv libs/* "$pkgdir"
74 # vim:set sw=2 sts=-1 et: