upgpkg: maxima 5.46.0-9 (sbcl rebuild)
[arch-packages.git] / cheese / trunk / PKGBUILD
blob998bcbaacb4f94a751ad9a4fd63205186b652a11
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=cheese
5 pkgname=(cheese libcheese)
6 pkgver=43.0
7 pkgrel=1
8 pkgdesc="Take photos and videos with your webcam, with fun graphical effects"
9 url="https://wiki.gnome.org/Apps/Cheese"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(gtk3 gstreamer gst-plugins-bad gst-plugins-base gst-plugins-good clutter-gst clutter-gtk
13          libcanberra librsvg gnome-desktop libgudev dconf gnome-video-effects)
14 makedepends=(gobject-introspection vala git appstream-glib meson yelp-tools)
15 checkdepends=(xorg-server-xvfb)
16 _commit=9e89a0da8d6d0da14b0b461051c064c419fc86d5  # tags/43.0^0
17 source=("git+https://gitlab.gnome.org/GNOME/cheese.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd cheese
22   git describe --tags | sed 's/\.\([a-z]\)/\1/;s/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd cheese
29 build() {
30   arch-meson cheese build -D tests=true
31   meson compile -C build
34 check() (
35   export GSETTINGS_SCHEMA_DIR="$PWD/cheese/data"
36   glib-compile-schemas "$GSETTINGS_SCHEMA_DIR"
38   dbus-run-session xvfb-run -s '-nolisten local' \
39     meson test -C build --print-errorlogs
42 _pick() {
43   local p="$1" f d; shift
44   for f; do
45     d="$srcdir/$p/${f#$pkgdir/}"
46     mkdir -p "$(dirname "$d")"
47     mv "$f" "$d"
48     rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
49   done
52 package_cheese() {
53   depends+=("libcheese=$pkgver-$pkgrel")
54   groups=(gnome)
56   meson install -C build --destdir "$pkgdir"
58   cd "$pkgdir"
60   _pick libs usr/include
61   _pick libs usr/lib/{girepository-1.0,libcheese*,pkgconfig}
62   _pick libs usr/share/{gir-1.0,glib-2.0/schemas,gtk-doc}
65 package_libcheese() {
66   pkgdesc="Webcam widget for Clutter and GTK"
67   depends=(clutter clutter-gtk clutter-gst gdk-pixbuf2 glib2 gtk3 libcanberra
68            gstreamer gst-plugins-base-libs gst-plugins-bad-libs)
69   provides=(libcheese.so libcheese-gtk.so)
70   mv libs/* "$pkgdir"
73 # vim:set sw=2 sts=-1 et: