upgpkg: maxima 5.46.0-9 (sbcl rebuild)
[arch-packages.git] / dolphin-plugins / kde-unstable / PKGBUILD
blobff045401b33ab95ec5bcb54fd1181628d8a659b1
1 # Maintainer: Antonio Rojas <arojas@archlinux,org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=dolphin-plugins
6 pkgver=23.03.90
7 pkgrel=1
8 pkgdesc='Extra Dolphin plugins'
9 arch=(x86_64)
10 url='https://apps.kde.org/dolphin_plugins/'
11 license=(LGPL)
12 depends=(dolphin)
13 makedepends=(extra-cmake-modules ktexteditor)
14 optdepends=('ktexteditor: Mercurial plugin')
15 groups=(kde-applications kdesdk)
16 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('fc9cd4e9e0758a6f25c8215e5dedd99e4d107a321781eaed514cca9986e69831'
18             'SKIP')
19 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
20               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
21               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
23 build() {
24   cmake -B build -S $pkgname-$pkgver \
25     -DBUILD_TESTING=OFF
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build