upgpkg: maxima 5.46.0-9 (sbcl rebuild)
[arch-packages.git] / evolution-ews / trunk / PKGBUILD
blobfd1cb6f2a6951146e1489aab0c63e9f3a84e242d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=evolution-ews
5 pkgver=3.46.4
6 pkgrel=1
7 pkgdesc="MS Exchange integration through Exchange Web Services"
8 url="https://wiki.gnome.org/Apps/Evolution/EWS"
9 arch=(x86_64)
10 license=(LGPL2.1)
11 depends=(libmspack evolution)
12 makedepends=(git intltool python cmake ninja systemd)
13 _commit=4628be92d70e3bbfad8e80db403d724c511feb87  # tags/3.46.4^0
14 source=("git+https://gitlab.gnome.org/GNOME/evolution-ews.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   cmake -S $pkgname -B build -G Ninja \
28     -DCMAKE_INSTALL_PREFIX=/usr \
29     -DLIBEXEC_INSTALL_DIR=/usr/lib \
30     -DSYSCONF_INSTALL_DIR=/etc
31   cmake --build build
34 package() {
35   DESTDIR="$pkgdir" cmake --install build
38 # vim:set sw=2 sts=-1 et: