upgpkg: maxima 5.46.0-9 (sbcl rebuild)
[arch-packages.git] / geeqie / trunk / PKGBUILD
blobc943bca925a55c672e4f2286870c76797126aa98
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
3 # Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
5 pkgname=geeqie
6 pkgver=2.0.1
7 pkgrel=5
8 pkgdesc='Lightweight image viewer'
9 arch=('x86_64')
10 url="http://www.geeqie.org/"
11 license=('GPL2')
12 # https://github.com/BestImageViewer/geeqie#optional-libraries
13 depends=('exiv2' 'gtk3' 'ffmpegthumbnailer'
14          'djvulibre' 'libheif' 'libchamplain'
15          'poppler-glib' 'libarchive' 'libraw' 'lua53'
16          'libjxl' 'gspell')
17 makedepends=('meson'
18              'intltool' 'python' 'librsvg'
19              'vim'
20              'libwmf' 'libwebp' 'imagemagick'
21              'fbida' 'gawk' 'perl-image-exiftool'
22              # for the docs
23              'doxygen' 'yelp-tools' 'graphviz'
25 optdepends=('librsvg: SVG rendering'
26             'fbida: for jpeg rotation'
27             'gawk: to use the geo-decode function'
28             'perl-image-exiftool: for the jpeg extraction plugin'
29             'gphoto2: command-line tools for various (plugin) operations'
30             'imagemagick: command-line tools for various (plugin) operations')
31 source=(#"http://www.geeqie.org/${pkgname}-${pkgver}.tar.xz"{,.asc}
32         https://github.com/BestImageViewer/geeqie/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz{,.asc}
34 sha256sums=('89c1a7574cfe3888972d10723f4cf3a277249bea494fd9c630aa8d0df944555d'
35             'SKIP')
36 validpgpkeys=('91EC400226201276E2ADCEC7D0DA6F44C936D1DA') # "Colin Clark <colin.clark@cclark.uk>"
38 # main repo: http://www.geeqie.org/cgi-bin/gitweb.cgi?p=geeqie.git
39 # bug tracker: https://github.com/BestImageViewer/geeqie/issues
41 build() {
42   arch-meson $pkgname-$pkgver build
43   meson compile -C build
46 check() {
47   meson test -C build
50 package(){
51   DESTDIR="$pkgdir" meson install -C build