upgpkg: maxima 5.46.0-9 (sbcl rebuild)
[arch-packages.git] / hyphen / trunk / PKGBUILD
blobcf51f9b28a04afc87222f1774ec776b39a687303
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgbase=hyphen
4 pkgname=('hyphen' 'hyphen-en')
5 pkgver=2.8.8
6 pkgrel=5
7 arch=('x86_64')
8 url="https://hunspell.sf.net"
9 license=('GPL2' 'LGPL2.1' 'MPL')
10 makedepends=('glibc' 'perl')
11 source=(https://downloads.sourceforge.net/hunspell/${pkgname}-${pkgver}.tar.gz)
12 sha1sums=('0556c392beb59433e577e3517575801212201df6')
13 sha256sums=('304636d4eccd81a14b6914d07b84c79ebb815288c76fe027b9ebff6ff24d5705')
15 build() {
16   cd "$pkgname"-$pkgver
17   ./configure --prefix=/usr --disable-static
18   make
21 package_hyphen() {
22  pkgdesc="library for high quality hyphenation and justification"
23  depends=('glibc' 'perl')
25   cd "$pkgbase"-$pkgver
26   make DESTDIR="$pkgdir/" install-libLTLIBRARIES
27   make DESTDIR="$pkgdir/" install-binSCRIPTS
28   make DESTDIR="$pkgdir/" install-includeHEADERS
29   
30   # license
31   install -D -m644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
34 package_hyphen-en() {
35  pkgdesc="English hyphenation rules"
36  # arch=('any')
37  optdepends=('hyphen: offers hyphenation library functions')
39   cd "$pkgbase"-$pkgver
40   make DESTDIR="$pkgdir/" install-hyphDATA
42   pushd ${pkgdir}/usr/share/hyphen/
43    en_US_aliases="en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_HK en_IE en_IN en_JM en_NA en_NZ en_PH en_SG en_TT en_ZA en_ZW"
44    for lang in $en_US_aliases; do
45         ln -s hyph_en_US.dic hyph_$lang.dic
46    done
47   popd
48   
49   # the symlinks
50   install -dm755 ${pkgdir}/usr/share/myspell/dicts
51   pushd "$pkgdir"/usr/share/myspell/dicts
52     for file in "$pkgdir"/usr/share/hyphen/*; do
53       ln -sv /usr/share/hyphen/$(basename $file) .
54     done
55   popd