upgpkg: maxima 5.46.0-9 (sbcl rebuild)
[arch-packages.git] / kdenlive / repos / extra-x86_64 / PKGBUILD
blob3b7d0596274b1bf569cfd1927654cbbc8fb00f23
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: Zuf <kontakt.zuf@gmail.com>
4 # Contributor: Darwin Bautista <djclue917@gmail.com>
5 # Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
7 pkgname=kdenlive
8 pkgver=22.12.3
9 pkgrel=1
10 pkgdesc='A non-linear video editor for Linux using the MLT video framework'
11 arch=(x86_64)
12 url='https://apps.kde.org/kdenlive/'
13 license=(GPL)
14 groups=(kde-applications kde-multimedia)
15 depends=(qt5-networkauth knewstuff knotifyconfig kfilemetadata purpose mlt breeze-icons frei0r-plugins)
16 makedepends=(extra-cmake-modules kdoctools v4l-utils doxygen qt5-tools)
17 optdepends=('ffmpeg: for FFmpeg plugin'
18             'dvgrab: for firewire capture'
19             'recordmydesktop: for screen capture'
20             'opencv: for motion tracking'
21             'plasma-desktop: theme configuration'
22             'opentimelineio: timeline export/import'
23             'bigsh0t: VR360 effects'
24             'mediainfo: for technical clip information'
25             'noise-suppression-for-voice: noise suppression effect')
26 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
27 sha256sums=('72ee0cbbe3302f03170049c0e0e427a5017cf995f6e5f4585f399224627c3c69'
28             'SKIP')
29 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
30               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
31               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
33 build() {
34   cmake -B build -S $pkgname-$pkgver \
35     -DBUILD_TESTING=OFF \
36     -DBUILD_QCH=ON
37   cmake --build build
40 package() {
41   DESTDIR="$pkgdir" cmake --install build