upgpkg: maxima 5.46.0-9 (sbcl rebuild)
[arch-packages.git] / libgweather-4 / trunk / PKGBUILD
blobb8428bda4b260278c297c5fcefd90678ef5a49fe
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=libgweather-4
5 pkgname=(libgweather-4 libgweather-4-docs)
6 pkgver=4.2.0
7 pkgrel=1
8 pkgdesc="Location and timezone database and weather-lookup library"
9 url="https://wiki.gnome.org/Projects/LibGWeather"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(libsoup3 geocode-glib-2 dconf libxml2)
13 makedepends=(gobject-introspection vala git gi-docgen meson python-gobject)
14 checkdepends=(python-pylint)
15 _commit=699cfb7e114acba4e066ebda9a51e6820da3daa7  # tags/4.2.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/libgweather.git#commit=$_commit"
17         disable-metar-test.diff)
18 sha256sums=('SKIP'
19             '42ebd95b2de37ff959a759546473985a86fa1a5488211b303a97540f2b7a8805')
21 pkgver() {
22   cd libgweather
23   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd libgweather
29   # Disable metar test, depends on unstable online service
30   git apply -3 ../disable-metar-test.diff
33 build() {
34   arch-meson libgweather build -D gtk_doc=true
35   meson compile -C build
38 check() {
39   meson test -C build --print-errorlogs
42 package_libgweather-4() {
43   provides=(libgweather-4.so)
45   meson install -C build --destdir "$pkgdir"
47   mkdir -p doc/usr/share
48   mv {"$pkgdir",doc}/usr/share/doc
51 package_libgweather-4-docs() {
52   pkgdesc+=" (documentation)"
53   depends=()
55   mv doc/* "$pkgdir"
58 # vim:set sw=2 et: