1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=python-dbusmock
6 pkgdesc="Mock D-Bus objects for tests"
7 url="https://github.com/martinpitt/python-dbusmock"
10 depends=(python-dbus python-gobject)
11 makedepends=(python-setuptools python-setuptools-scm python-build
12 python-installer python-wheel git)
13 _commit=276f54de0f653e8a37b0d0392450df3f57b0a746 # tags/0.28.6^0
14 source=("git+https://github.com/martinpitt/python-dbusmock#commit=$_commit"
15 0001-Fix-OBEX-PullAll-after-pathlib-conversion.patch)
17 'd259cbecb464ad5ea782f43ca630062ffa03feb6017825a3b7ac235d910ba798')
19 # Suppress local version
20 export SETUPTOOLS_SCM_PRETEND_VERSION="${pkgver%%+*}"
24 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 git apply -3 ../0001-Fix-OBEX-PullAll-after-pathlib-conversion.patch
34 python -m build --wheel --no-isolation
39 python -m installer --destdir="$pkgdir" dist/*.whl
42 # vim:set sw=2 sts=-1 et: