1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-languageserver
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='An implementation of the Language Server Protocol'
13 makedepends=(cmake ninja)
15 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
16 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
17 sha256sums=('5909b96e0241f41c9ba05240248287c643a7440f81450401d1b0d51ba9a56a61')
20 cmake -B build -S $_pkgfn -G Ninja \
21 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
26 DESTDIR="$pkgdir" cmake --install build
28 install -d "$pkgdir"/usr/share/licenses
29 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname