OCaml 4.14.0 rebuild
[arch-packages.git] / libchamplain / trunk / PKGBUILD
blob14d16ba83f54ad34c25d58515105cbc0e1a667f3
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Andreas Radke <andyrtr@archlinux.org>
3 # Contributor: Michael Kanis <mkanis@gmx.de>
5 pkgname=libchamplain
6 pkgver=0.12.20
7 pkgrel=3
8 pkgdesc="A map widget"
9 url="https://wiki.gnome.org/Projects/libchamplain"
10 license=(LGPL)
11 arch=(x86_64)
12 depends=(clutter-gtk libsoup cairo sqlite)
13 makedepends=(gobject-introspection gtk-doc vala meson git)
14 options=(debug)
15 _commit=145e417f32e507b63c21ad4e915b808a6174099e  # tags/LIBCHAMPLAIN_0_12_20^0
16 source=("git+https://gitlab.gnome.org/GNOME/libchamplain.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/^LIBCHAMPLAIN_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build -D gtk_doc=true
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"