OCaml 4.14.0 rebuild
[arch-packages.git] / telepathy-mission-control / repos / extra-x86_64 / PKGBUILD
blob0ba48cfe97b432ed99c203eed79c1fb9081b9b4c
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Ju Liu <liuju86 at gmail dot com>
4 # Contributor: Bjorn Lindeijer <bjorn lindeijer nl>
5 # Contributor: Andreas Zwinkau <beza1e1@web.de>
7 pkgname=telepathy-mission-control
8 pkgver=5.16.6
9 pkgrel=2
10 pkgdesc='A Telepathy component providing abstraction of some of the details of connection managers'
11 arch=(x86_64)
12 url='https://telepathy.freedesktop.org/'
13 license=(LGPL2.1)
14 depends=(telepathy-glib dconf libnm)
15 makedepends=(libxslt python gtk-doc)
16 source=(https://telepathy.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.gz{,.asc})
17 sha256sums=('2df8ae3995e919a7670e01aa3568215ef0777e34961ace1cac1c6477cb297a45'
18             'SKIP')
19 validpgpkeys=(38FDAD7D73CE1AE7A16200291F3845DD1432A9FB  # Georgios Kiagiadakis <gkiagia@tolabaki.gr>
20               AA33B0D27868E36C151780F0FE0B6D736B1195ED) # Alexandr Akulich <akulichalexander@gmail.com>
22 build() {
23   cd $pkgname-$pkgver
24   ./configure --prefix=/usr --libexecdir=/usr/lib/telepathy \
25       --with-connectivity=nm \
26       --enable-gtk-doc \
27       --disable-upower \
28       --disable-static \
29       --disable-schemas-compile
30   make
33 package() {
34   cd $pkgname-$pkgver
35   make DESTDIR="$pkgdir" install